Bugtracker DMXControl 3

  • Status Benötigt Tests
  • Percent Complete
    80%
  • Task Type Fehlerbericht
  • Category GUI & Server
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Reported Version 3.3 Beta x
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: DMXControl 3
Opened by MisterX - 02.03.2022

FS#4790 - Keine Verbindung zwischen Kernel, GUI und Umbra wenn ein VPN aktiv ist

Starte ich die Software mit aktivertem VPN bleibt der Network-Explorer leer und es kann keine Verbindung zwischen den Programmteilen hergestellt werden.
Deaktiviere ich das VPN, in meinem Fall Wireguard, und starte die Software erneut klappt es. Wenn die Verbindung steht kann ich das VPN wieder aktivieren und die Software funktioniert weiter.

LightningBrothers commented on 25.03.2022 19:44

Diesen Punkt würde ich mittlerweile ausweiten und dahingehend formulieren, dass keine Verbindung zwischen Kernel, Umbra und GUI aufgebaut werden kann, wenn der PC grundsätzlich mit zwei Netzwerken verbunden ist oder war. In meinem Fall hatten meine Laptops anfangs erst noch eine Netzwerkverbindung sowohl per LAN als auch per WLAN ins selbe Netzwerk. Erst nachdem ich die WLAN-Verbindung abgeschaltet und den PC neugestartet habe, konnte eine entsprechende Verbindung aufgebaut werden.

Project Manager
Soon5 commented on 31.03.2022 06:54

Das Problem ist, wenn mehrere Schnittstellen existieren, die ins gleiche Netzwerk zeigen, oder sonst wie der "Unicast" unterbunden wird. Hier haben wir leider wenig Einfluss.

@MisterX Kannst du bei eingeschaltetem VPN mal in der Windows Konsole ein "ipconfig /all" machen und uns das schicken? Dann sieht man, welche IPs wie wo verteilt sind.

Project Manager
Soon5 commented on 31.03.2022 07:39

Ich kanns bei mir nicht reproduzieren, aber ich hab mal was eingebaut, in der Hoffnung dass es das Problem behebt. Bitte in der nächsten Beta Version (2) dann testen.

Project Manager
Soon5 commented on 31.03.2022 13:11

Also.

Es sind zwei unterschiedliche Fehler. Den Fehler von Stefan konnte ich denke ich finden. Das kann in Beta 2 getestet werden. Der VPN Fehler kann auch damit zusammenhängen wie das Routing auf dem PC gemacht wird, wenn der VPN Client aktiv ist. Da hat man dann halt verloren.

MisterX commented on 13.04.2022 18:16

Habe irgendwie für das Thema keine Benachrichtigung bekommen, daher jetzt verspätet meine Antwort.
Im Anhang die Ausgabe jeweils mit und ohne VPN.
Wenn es nicht zu lösen ist wäre zumindest ein Hinweis auf mögliche/bekannte Fehlerursachen gut.

Project Manager
Soon5 commented on 24.08.2022 09:16

Kannst du mal die Ausgabe von "route print" ausgeben? Wieder jeweils mit Wireguard aktiv und inaktiv.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing