Bugtracker DMXControl 3

  • Status Benötigt Tests
  • Percent Complete
    80%
  • Task Type Fehlerbericht
  • Category GUI & Server → Server
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Medium
  • Reported Version 3.2.2 Beta x
  • Due in Version 3.3
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: DMXControl 3
Opened by JPK - 13.09.2020
Last edited by JPK - 31.05.2021

FS#4271 - Werte in Matrix bleiben trotz Löschen aus Programmer bestehen

Steuert man mit einer Matrix mehrere Geräte oder Sub-Matrizen an, so bleibt die Ausgabe beim Löschen von Werten aus dem Programmer weiter bestehen. Folgendermaßen lässt sich das Problem reproduzieren:

  1. Lege 4 Geräte an
  2. Lege eine 4×1 Matrix an
  3. Patche die Geräte auf die Matrix
  4. Wähle die Matrix in der Stage View aus
  5. Klicke auf den Lumos Button
  6. Stelle eine Farbe für die Matrix ein
  7. Gehe nun in den Programmer und lösche den Farbwert für die Matrix

Problem: Die LED-Scheinwerfer behalten nun den letzten Farbzustand, obwohl kein Wert mehr gesetzt ist. Sie gehen erst aus, wenn man den Programmer über “Clear” leert

Erwartetes Verhalten: Die Matrix verhält sich hier wie eine Art Gerätegruppe, wenn also die Werte der Matrix gelöscht werden, muss die Ausgabe der zugeordneten Geräte auch gelöscht werden

Project Manager
Soon5 commented on 14.09.2020 11:09

Die Scheinwerfer bleiben an, behalten also die Farbe (z.B. Blau), oder die Scheinwerfer wechseln auf Weiß zurück?

Admin
JPK commented on 14.09.2020 13:54

Die Scheinwerfer behalten den letzten Zustand. Wenn ich also beispielsweise einen Plasma-Effekt auf die Matrix gelegt habe und diese lösche, behalten die Scheinwerfer den Zustand des Plasma-Effekts zum Zeitpunkt des Löschens. (habe das mal im Ticket konkretisiert). Im Ticket hatte ich das mit dem Dimmer vermischt, denn wenn ich den Dimmer der Matrix lösche, bleiben die Scheinwerfer an (also auch hier der letzte Zustand der Matrix).

Project Manager
Soon5 commented on 14.09.2020 14:53

Alles klar. Ich denke ich weiß wo das Problem liegt. Wegen interner umbauten wird das aber erst mit der 3.3 behoben werden. Da ist das wesentlich einfacher zu lösen.

EDIT: Ich Idiot hab mir mal wieder nicht notiert WAS das Problem ist…… Also muss ich mir das in der 3.3 dann nochmal "erdebuggen"…….

JohannesStroe commented on 28.06.2021 23:14

Funktionert

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing