Bugtracker DMXControl 3

  • Status Benötigt Tests
  • Percent Complete
    100%
  • Task Type Fehlerbericht
  • Category GUI & Server → InputAssignment
  • Assigned To
    Arne Lüdtke
  • Operating System All
  • Severity Medium
  • Priority Low
  • Reported Version 3.2 Beta x
  • Due in Version 3.2
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: DMXControl 3
Opened by Stefan Kistner - 16.07.2019

FS#3705 - Verbindungen nach Laden des Projekts auf "On Hold"

Lade ich ein vorhandenes Projekt, sind die Verbindungen im Input Assignment trotz aktiver Bank “On Hold” und warten quasi auf einen Initialisierungsimpuls. Aufgefallen ist mir dies in folgender Konstellation:

Ich habe zwei verschiedene Verbindungen. Die Schnittmenge beider Verbindung ist der Speedmaster 1. In der Verbindung 1 (Beat Tastatur) triggere ich den Speedmaster 1 über die Tastatur. In der Verbindung 2 (Beat Softdesk) triggere ich den gleichen Speedmaster über den Button des Softdesks und nutze diese Verbindung auch, um mir den aktuellen BPM-Wert im Softdesk anzuzeigen.

Triggere ich den Speedmaster 1 über die Tastatur, kommen die Werte nach dem Laden des Projekts zwar beim Speedmaster an. Das Feedback ans Softdesk über die Verbindung 2 erhalte ich erst, wenn ich dieser Verbindung einen einmaligen Impuls gebe, entweder

  • über einen verfügbaren Input (in diesem Fall der Button, der auch den BPM-Wert anzeigt) oder
  • durch Deaktivieren und Aktivieren der Verbindung 2 (Beat Softdesk) oder
  • in diesem Fall durch Änderung der Einstellung des Speedmaster 1 in der Verbindung selbst.

Um den besagten Aktualisierungs- bzw. Initialisierungsimpuls zu generieren, reicht es nicht, die komplette Bank zu deaktivieren und wieder zu aktivieren. Dass dieser fehlt, kann man auch daran erkennen, dass an den Nodes kleine Statuswerte angezeigt werden.

Zum Nachstellen des Problems habe ich ein Beispielprojekt beigefügt. Die oben genannten Verbindungen sind in den ersten beiden Bänken im Input Assignment zu finden. Hierzu am besten das letzte Fensterlayout laden.

Project Manager
Arne Lüdtke commented on 24.07.2019 20:20

Ok. Da war ein Performance Problem in dem Graph Node. Ich hab das korrigiert, jetzt geht bei mir alles.

Patrick Meyer commented on 11.08.2019 19:08

Bei mir ist es so, dass ich auch einige Softdesk-Buttons einmal drücken muss, um sie "scharf" zu schalten. Erst dann funktionieren sie einwandfrei

Stefan Kistner commented on 11.08.2019 20:04

Ich habe hier auch das Gefühl, dass es ein wenig von der Größe des Projekts abhängt. Nachgestellt kann der Fehler mit dem von mir intern abgelegten Projekt, welches bereits zur Nachstellung des Fehlers  FS#3668  diente.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing