Bugtracker DMXControl 3

  • Status Closed
  • Percent Complete
    100%
  • Task Type Fehlerbericht
  • Category GUI & Server → InputAssignment
  • Assigned To
    Patrick Grote
  • Operating System All
  • Severity Very Low
  • Priority Very Low
  • Reported Version 3.2 Beta x
  • Due in Version 3.2
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: DMXControl 3
Opened by maik stolle - 07.07.2019
Last edited by Arne Lüdtke - 20.08.2019

FS#3673 - Darstellung des Graphen wird nicht gespeichert

beim verlassen der “Graphenansicht” wird die Platzierung der Nodes nicht gespeichert und jedesmal beim wieder öffnen wild durcheinander geschmissen.

Closed by  Arne Lüdtke
20.08.2019 18:56
Reason for closing:  Repariert
Project Manager
Patrick Grote commented on 07.07.2019 18:25

Eigentlich funktioniert das.

Aber auch für dich.

Logfiles und Project anhängen!

maik stolle commented on 07.07.2019 20:19

hi Patrick,

anbei alle log's und das Project

maik stolle commented on 08.07.2019 14:21

zur Info,

Fehler tritt nur auf wenn Sprache Deutsch eingestellt ist.

maik stolle commented on 08.07.2019 14:29

wenn graph mit eingestellter Sprache English gespeichert wird, und dann mit Deutscher Sprache geöffnet wird . sind die Positionen der Nodes IO (wie in english gespeichert).

maik stolle commented on 08.07.2019 15:30

jetzt taucht das Phänomen auch mit englisher Sprache auf.
Obwohl es vorher reproduzierbar war → deutsch ging nicht → english ging

also hier mal die log's mit englisher Sprache

Project Manager
Arne Lüdtke commented on 11.07.2019 19:27

Interessant. Eigentlich sollte alles passen….

Project Manager
Patrick Grote commented on 19.07.2019 16:01

Tritt das auch auf, wenn du die Nodes im Graphe mal verschoben hast, oder nur, wenn du die Nodes nie verschoben hast?

maik stolle commented on 21.07.2019 07:09

das Problem triit auf, wenn ich die Graphen anordne (verschiebe) entweder von Hand oder Auto.
Wenn ich nun wider in die Showtable Ansicht wechsle und dann wieder in die Showgraph, werden alle wieder wild durcheinander geworfen.
Mit wild ist zu verstehen, die Positionen die sie hatten beim Hinzufügen.

Project Manager
Patrick Grote commented on 21.07.2019 10:38

Tritt das nur bei Graphen auf, in denen SoftDesk-Controls sind?

maik stolle commented on 21.07.2019 13:39

ähm mit allen, zb. Button,converter, math,cuelist

Project Manager
Patrick Grote commented on 21.07.2019 15:09

Nein, du hast mich falsch verstanden.

Ist in den betroffenen Graphen MINDESTENS EIN SoftDesk-Control

Und sind Graphen, in denen KEIN Softdesk-Control ist das Problem nicht???

maik stolle commented on 21.07.2019 15:34

also,

habe mal einen Graphen ohne softdesk Elemente erstellet und der Fehler trat nur 3 von 20 mal auf.

mit Softdesk Element 19 von 20 mal.

maik stolle commented on 21.07.2019 15:42

hier mal ein kurzes Video mit der "autoposition Funktion" die Positionen werden erst beim 2ten Versuch gespeichert (reproduzierbar)

beim verschieben von Hand ist die reproduzierbarkeit sehr schwankend

egal ob mit oder ohne softdesk elemente

Project Manager
Patrick Grote commented on 21.07.2019 16:02

Dann hab ich das gefixt

Joseph Noetzel commented on 18.08.2019 18:38

@Maik Ist der Fehler mit der Beta 5 nun gefixt?

maik stolle commented on 19.08.2019 04:16

Hi,

grade mal die beta5 installiert und getestet.
leider geht das noch nicht richtig, die Position wird erst beim 2ten Versuch gespeichert.

siehe Video

maik stolle commented on 19.08.2019 04:18

Dies gilt auch für die Auto Position Funktion!

anbei die log's

Project Manager
Arne Lüdtke commented on 20.08.2019 18:56

Habs gefunden. Sollte in BETA6 / RC1 behoben sein.

EDIT: Als Workaround zum Öffnen der Graphenansicht in der Tabelle immer in die 1. Spalte doppelt klicken, sodass die ganze Zeile selektiert ist.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing