Bugtracker DMXControl 3

  • Status Neu
  • Prozent erledigt
    0%
  • Aufgabentyp Fehlerbericht
  • Kategorie Server
  • zuständig niemand
  • Betriebssystem All
  • Schweregrad niedrig
  • Dringlichkeit gering
  • betrifft Version 3.1.2
  • fällig in Version unbestimmt
  • fällig am unbestimmt
  • Stimmen
  • versteckt
gehört zu Projekt: DMXControl 3
angelegt von Patrick Meyer - 19.06.2018
zuletzt bearbeitet von Patrick Meyer - 19.06.2018

FS#3093 - Fanning auf Strobekanal, welcher durch 2 verschiedene DDFs angesprochen wird

Ich habe noch einen Bug gefunden, der aber höchst selten auftreten wird. Dazu eine kurze Erklärung:

Ich habe ein Gerät, welches ich in 2 ddfs aufgeteilt habe, um DMXC3 voll ausreizen zu können. (https://m.ebay.de/itm/90WDMX51…ht-Party-YA-/282536766342)

Jede Walze hat also ihr eigenes ddf. Die strobe Funktion ist jedoch nur einmal vorhanden. Also habe ich in beiden ddfs den strobe Kanal angegeben( ich hatte auch versucht, nur in einem ddf den strobe Kanal anzugeben, jedoch fügt dmxc3 dann bei dem 2. Gerät einen virtuellen strobe ein und das funktioniert dann natürlich nicht...)

Da ich 2 dieser Geräte(somit 4 ddfs) habe, liegen alle 4 Walzen in einer Gruppe. Nun wollte ich auf dem strobe Kanal ein fanning anwenden: 4>8.

Somit liegen auf einem Kanal verschiedene Werte.

Dann gibt es ein seltsames Verhalten: Der Rot Kanal wird angesprochen. Jedoch erscheint davon nichts in der channel over view. Auch ein klick auf Clear Programmer bringt keine Hilfe. Die rote Led bleibt an. Lediglich das Aus- und wieder einschalten des Interfaces löscht den Rot-Wert.

Siehe Video in dem gepackten Ordner

Das Verhalten ist 100%ig reproduzierbar.

Das Projekt im Ordner ist neu erstellt mit nur den benötigten devices.

   Bug.zip (98,33 MB)
Project Manager
Arne Lüdtke schrieb am 20.06.2018 18:35

Also dazu ist erst mal zu sagen, dass es immer zu komischem verhalten kommen kann, wenn sich DDFs überlappen. Ich schaue es mir aber an.

Hast du den Fehler auch, wenn du wie vorgeschlagen nur in 1 Gerät den Strobe Kanal definierst und dann den Strobo NICHT über die Gruppe ansteuerst, sondern nur über das 1 Gerät?

Was eine interessante Idee ist, ist das man bei Geräten evtl. das generieren eines virtuellen Strobes im DDF abschalten kann.

Patrick Meyer schrieb am 20.06.2018 18:43

Nein. Ich habe den Fehler für mich behoben, indem ich auf dem zweiten Gerät den strobekanal auf einen undefinierten Kanal hinter die eigentliche Belegung gesetzt habe. Somit gab es keine Fehler mehr.

Ich habe im Kernelmenü mal die dmx-Ausgabe auf dem besagten Rotkanal beobachtet und dort gab es keine Aktivitäten.

Lade...

Verfügbare Tastenkürzel

Aufgabenliste

Aufgabendetails

Aufgabenbearbeitung